Checkouts complete and no further reports from AWS in relation to any downtime expected. Root Cause Analysis will be published when provided by AWS.
Posted Oct 20, 2025 - 12:07 UTC
Update
Services are returning to normal after the latest update provided by AWS. Both Studio and Web Experience and all other channels are available. We are performing checkouts on all services. StatusPage will be set to Monitoring until AWS advises this issue has been fully resolved.
Posted Oct 20, 2025 - 09:37 UTC
Update
Update provided by AWS:
We have applied initial mitigations and we are observing early signs of recovery for some impacted AWS Services. During this time, requests may continue to fail as we work toward full resolution. We recommend customers retry failed requests. While requests begin succeeding, there may be additional latency and some services will have a backlog of work to work through, which may take additional time to fully process. We will continue to provide updates as we have more information to share, or by 3:15 AM.
Posted Oct 20, 2025 - 09:33 UTC
Identified
Update from AWS Oct 20 2:01 AM PDT We have identified a potential root cause for error rates.... Based on our investigation, the issue appears to be related to DNS resolution of the DynamoDB API endpoint in US-EAST-1. We are working on multiple parallel paths to accelerate recovery.... We will continue to provide updates as we have more information to share, or by 2:45 AM.
Posted Oct 20, 2025 - 09:07 UTC
Update
Update provided by AWS: We can confirm increased error rates and latencies for multiple AWS Services in the US. This issue may also be affecting Case Creation through the AWS Support Center or the Support API. We are actively engaged and working to both mitigate the issue and understand root cause. We will provide an update in 45 minutes, or sooner if we have additional information to share.
Posted Oct 20, 2025 - 07:57 UTC
Investigating
Both Web Experience and Studio are currently down for US customers, EU Web Experience and Studio are available. The issue is linked to a broader AWS outage impacting US customers. We have reached out to AWS for updates.
Posted Oct 20, 2025 - 07:44 UTC
This incident affected: Platforms (US Firstup Platform) and Products (Campaign Delivery, Creator Studio, Classic Studio, Web Experience, Mobile Experience, Microapps, Insights).