Platform Service Degradation - New Studio is Slow or Unresponsive
Incident Report for Firstup
Resolved
Our monitoring has indicated that New Studio has remained available and responsive.

This incident is now resolved.
Posted Mar 08, 2023 - 01:52 UTC
Monitoring
A fix has been implemented, and New Studio is now fully responsive. Please note that a refresh of the New Studio page may be required for the changes to be effective on the user side.

We will monitor this service for stability.
Posted Mar 07, 2023 - 23:34 UTC
Identified
A potential cause for this service degradation has been identified, and we are working to mitigate it.

Another update to follow as soon as more information is made available.
Posted Mar 07, 2023 - 20:49 UTC
Investigating
We are investigation reports where New Studio is slow to load or unresponsive.

We will provide another update as soon as more information is made available.
Posted Mar 07, 2023 - 18:57 UTC
This incident affected: Products (New Studio).