Platform Service Degradation - Studio Unavailable
Incident Report for Firstup
Postmortem

On February 12th, 2024, starting at around 9:20 AM ET, we received reports that some users were experiencing issues accessing Creator Studio. The reports included general slowness loading Studio functions, as well as system error messages such as “Failed to fetch. Try again” or “504 Bad Gateway”.

 

During our investigations, it was identified that the number of available database connections was exhausted, and therefore new Creator Studio requests could not establish a connection to the database.

 

To mitigate this situation, a rolling redeployment of dependent backend services that had connections to the database was performed to free up any “stuck” connections, thus allowing new Creator Studio requests to connect to the database.

 

As a recurrence prevention measure to this incident, we are working on reducing the demand for database connections in the short term via methods such as:

  • Connection pooling
  • Read/write splitting

In the long term, we will be looking at:

  • Upgrading our database infrastructure
  • Increasing our database connection limits.
Posted Feb 29, 2024 - 19:30 UTC

Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 17:47 UTC
Monitoring
We have corrected the database issue to mitigate this incident, and Studio should now be available and accessible.

We will be placing this incident under monitoring.
Posted Feb 12, 2024 - 15:12 UTC
Identified
We have identified a potential database issue that may be causing Studio to be unavailable, and are working to correct this issue.

Another update with half an hour.
Posted Feb 12, 2024 - 15:03 UTC
Investigating
We are currently investigating reports where Studio is currently unavailable.

We will provide you with an update within half an hour.
Posted Feb 12, 2024 - 14:47 UTC
This incident affected: Products (New Studio) and Platforms (US Firstup Platform).