Unable to post comments on Microapps and Content
Incident Report for Firstup
Postmortem

On 6/1/2023 at 10:55 AM PST, Firstup platform had an increase in commenting on posts which put stress on our database. Due to a sudden influx of a high volume of comments a safety mechanism was automatically triggered which limited additional comments from being able to post. This mechanism was put in place from platform incident on 2/2/2023 to reduce extra extraneous load on the database caching service in order to prevent impact from spreading to other (non-commenting related) micro services. We have implemented a performance enhancement by removing a bottleneck in the process of users submitting comments.

Posted Jun 09, 2023 - 22:47 UTC

Resolved
Our extensive monitoring has indicated that all affected systems have remained stable and fully functional.

This incident will now be resolved, and a root cause analysis will be provided once a postmortem has been completed.
Posted Jun 02, 2023 - 13:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2023 - 19:30 UTC
Identified
We have identified the issue that is causing this service degradation with unable to comment, and are currently working on a fix for it.

Another update will be provided within the next 1 hour.
Posted Jun 01, 2023 - 18:39 UTC
Investigating
We are currently investigating reports of unable to post comments on Microapps and Content
Posted Jun 01, 2023 - 18:06 UTC
This incident affected: Products (New Studio, Microapps) and Platforms (US Firstup Platform).