Twitter Breaking Change...
Incident Report for Firstup
Resolved
Marking this issue as resolved. This incident was opened initially as risk-based, and then evolved in to two separate service disruptions that were subsequently mitigated. We do not feel there is any near-term risk of recurrence now having re-established contacts with the social media platform, good progress towards moving to the updated API, and a developer subscription under Twitter's new service plans.
Posted Jun 16, 2023 - 00:17 UTC
Update
Twitter feeds should now all be refreshed, and the incident has once again been mitigated. Work continues for the long-term fix on the new version of Twitter's API and service tier, but we believe any recurrent disruption of service between now and then to be highly unlikely. Moving incident back to monitoring state and marking all components fully operational.
Posted May 03, 2023 - 00:20 UTC
Identified
We are aware of Twitter feeds not refreshing/updating as expected since 4/25. This is due to a change from Twitter and we are working to resolve it. Currently, we do not have an ETA but we will keep you up to date as Firstup makes progress.
Posted May 01, 2023 - 18:14 UTC
Monitoring
Impact has been mitigated, and all connected Twitter feeds have been successfully refreshed. There remains a high probability of a recurrence between now and end of next week, when we have fully implemented and tested Twitter integration with their new API. In the interim, we will continue to monitor for any disruptions and do what we can to minimize any service impact to the Firstup platform.
Posted Apr 07, 2023 - 21:44 UTC
Investigating
Moving this incident out of a risk-only designation. We have observed unexpected failures with Twitter API calls. We are currently investigating the reason behind the errors, but all content pulled in from Twitter sources for content feeds will fail in the interim.
Posted Apr 07, 2023 - 18:59 UTC
Identified
Twitter has announced new access tiers to their platform API as well as a stated requirement for all developers to port any applications to the new version 2 of the API within 30 days or less. We have spun up a developer work stream to make these updates so that connected Twitter accounts can remain a viable a source for content feeds. Firstup remains committed to providing the best functionality possible that the new Twitter API allows.
Posted Apr 04, 2023 - 20:24 UTC
Update
Twitter have sent a further update out that this change has been delayed for a few more days - no definite date has been provided as yet. Our Engineering Team will be reviewing all options from Twitter when fully known.
Posted Feb 14, 2023 - 21:07 UTC
Update
Twitter has moved this change window to Feb 13, 2023 so we do not expect any potential disruption of service tomorrow Feb 9, 2023. We will keep this incident open for communication updates however as the situation progresses.
Posted Feb 09, 2023 - 03:06 UTC
Investigating
We are initiating a platform incident for risk, based on the contents of a public tweet (https://twitter.com/TwitterDev/status/1621026986784337922) from the official Twitter Dev account, purporting that access to the Twitter API will require a "paid basic tier" as of February 9th. We have not received any further communication through alternate channels or via Twitter's Developer Team detailing exactly when/how this will be enforced and what it will ultimately look like.

Our Engineering Team remains at the ready to respond as necessary to make sensible adjustments that may be required to retain current interoperability between Twitter and the Firstup platform.

Further information will be posted in this platform-specific status page as it becomes available. If access to the Twitter API should be unexpectedly severed, that could impact content feeds configured to pull Twitter content in to Programs, but native sharing of content out to Twitter should continue to function as it does not utilize the Twitter Developer API.
Posted Feb 08, 2023 - 22:07 UTC
This incident affected: Products (New Studio) and Ecosystem (Integrations).