Residual slowness has been fully addressed and all components are now fully operational. Root cause ascertained, and impact has been fully mitigated. Risk of a recurrence is very low, but additional investigation is required for full resolution. This incident will remain in a monitoring status until that investigation and a recurrence prevention plan is committed, at which time an RCA (Root Cause Assessment) will be published.
Posted Oct 10, 2025 - 17:40 UTC
Update
All services have been restored and are fully operational. We will continue to monitor the impacted services.
Posted Oct 10, 2025 - 17:39 UTC
Update
We continue to monitor for any further issues.
Posted Oct 10, 2025 - 16:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 10, 2025 - 13:48 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 10, 2025 - 13:28 UTC
Identified
Web Experience is available and the load times have improved - we are continuing to monitor.
Posted Oct 10, 2025 - 13:22 UTC
Update
Work is continuing to fully restore service, improvements have been seen with Web Experience loading however it is still slow to load for some customers.
Posted Oct 10, 2025 - 12:58 UTC
Update
EU customers are not impacted. Investigation is continuing.
Posted Oct 10, 2025 - 12:31 UTC
Investigating
We are currently investigating a new platform incident impacting the web experience channel for some users. A 'oops something went wrong' error is being displayed on some programs. Updates to follow asap.
Posted Oct 10, 2025 - 12:27 UTC
This incident affects: Platforms (US Firstup Platform) and Products (Web Experience).