Platform Service Unavailable - Insights Reports

Incident Report for Firstup

Resolved

This incident is now resolved, and all impacted services have remained available and fully operational. A Root Cause Assessment will be provided here once a postmortem review of this incident is concluded.
Posted Oct 13, 2025 - 15:58 UTC

Monitoring

We have mitigated this incident, and Insights Reports on the Firstup US platform are now available. A screen refresh may be required to load the reports.

We will be placing the impacted components under monitoring for now.
Posted Oct 09, 2025 - 18:05 UTC

Investigating

We are currently investigating an issue where Studio Insights Reports are not available on the Firstup US platform.

We will provide you with an update within 1 hour.
Posted Oct 09, 2025 - 17:29 UTC
This incident affected: Products (Insights).