DNS issues have made Firstup Studio unavailable to some

Incident Report for Firstup

Postmortem

Summary: On February 10, 2026, between 20:47 UTC and 22:12 UTC, some customers experienced intermittent issues accessing Creator Studio. This was first observed internally and an incident was declared at 21:00 UTC.

The issue was traced to a global DNS outage within Amazon Web Services (AWS). The outage caused inconsistent domain name resolution for certain services that rely on AWS DNS infrastructure. Because the disruption occurred at the cloud provider level, impact varied by geographic location.

Once AWS resolved the underlying issue, service was fully restored.

Impact:

  • Creator Studio was intermittently unavailable for some users depending on geographic location and DNS resolver behavior.
  • The issue was transient in nature but inconsistent; some users were able to access services while others could not, depending on how DNS responses were propagated in their region.
  • The disruption lasted approximately 1 hour and 25 minutes.

Root Cause: AWS introduced a configuration change intended to improve its internal systems that inadvertently caused DNS records for some endpoints to resolve inconsistently across global DNS infrastructure.

Because Firstup relies on AWS DNS and content delivery infrastructure, customers experienced intermittent domain resolution failures. The issue was external to Firstup’s infrastructure and could only be resolved by AWS.Mitigation: Upon internal detection of the issue at 20:47 UTC, the Cloud Operations and Engineering teams declared an incident. An investigation quickly confirmed the issue originated within AWS services, and we engaged our AWS Technical Account Manager.

At 22:12 UTC, AWS confirmed the root cause of the issue was identified and significant recovery of the DNS propagation issue was seen. Firstup verified restoration through internal testing and confirmed access to affected services had returned to normal for all regions. AWS confirmed full resolution at 04:18 UTC.

Recurrence Prevention: While this incident was caused by a cloud provider disruption outside of Firstup’s direct control, we are taking steps to improve detection and visibility:

  • Reviewing and repairing monitoring for Studio availability.
  • Expanding monitoring coverage to include additional geographic regions.
  • Auditing existing alert ownership to ensure monitoring issues are surfaced and resolved promptly.
Posted Feb 21, 2026 - 01:54 UTC

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 18:52 UTC

Update

Amazon confirmed the issue has been fully resolved as of 8:18PM PT. Marking all components as fully operational.
Posted Feb 11, 2026 - 04:18 UTC

Monitoring

AWS has identified the root cause of the issue, implemented changes and can confirm significant recovery for the DNS resolution errors. There may still be some residual hiccups while the fixes propagate, however.
Posted Feb 10, 2026 - 22:20 UTC

Identified

AWS has identified an issue causing DNS resolution failures - more can be found here: https://health.aws.amazon.com/health/status
Posted Feb 10, 2026 - 21:22 UTC

Investigating

We are currently investigating this issue.
Posted Feb 10, 2026 - 21:09 UTC
This incident affected: Platforms (US Firstup Platform) and Products (Creator Studio).