Reports Service Disruption
Incident Report for Firstup
Resolved
Reports remain stable and available.

This service disruption is now resolved.
Posted Mar 19, 2023 - 01:34 UTC
Monitoring
Our upstream service provider's global outage has been reported as resolved. Reports are now available.

We will be placing Reports availability under monitoring.
Posted Mar 18, 2023 - 22:21 UTC
Investigating
Due to an upstream service provider global outage, Reports are currently unavailable.

We will provide you with another update as soon as the upstream service provider's global outage is resolved, and reports are restored.
Posted Mar 18, 2023 - 21:37 UTC
This incident affected: Products (Analyze).