Platform Service Degradation - Mobile Videos Not Rendering As Expected
Incident Report for Firstup
Postmortem

On May 31st 2023, at 10:31 AM Pacific Time, a configuration change intended to add flexibility in video display scaling resulted in prior videos to not be playable for Safari and iOS users due to a change in the naming convention of the stored video assets.

On June 1st 2023, at 1:21 PM Pacific Time, a fix was developed and deployed, and prior videos were backfilled by 2:10 PM Pacific Time to utilize the correct naming convention, allowing all videos to resume playing as expected.

Our QA testing has been revamped to include testing video assets and their use cases in the platform before any configuration change deployment, in an effort to prevent this scenario from happening again.

Posted Jun 09, 2023 - 19:11 UTC

Resolved
Our monitoring has indicated that mobile videos have been rendering as expected after the deployed fix.

This incident will now be placed in a resolved status.
Posted Jun 02, 2023 - 20:54 UTC
Monitoring
The developed fix for this issues has been vetted and deployed in the production environment, and mobile videos should now be rendering as expected.

We will be placing this service under monitoring to ensure stability.
Posted Jun 01, 2023 - 21:04 UTC
Update
A fix for this issue has been developed, and is currently undergoing QA testing and final approval.

Another update will be provided within 1 hour.
Posted Jun 01, 2023 - 19:56 UTC
Update
We continue to work on a fix for this issue, and will provide another update within the next 1 hour.
Posted Jun 01, 2023 - 19:10 UTC
Update
We continue to work on a fix for this issue, and will provide another update within the next 1 hour.
Posted Jun 01, 2023 - 18:07 UTC
Identified
We have identified a potential configuration issue that is causing this service degradation, and are currently working on a fix for it.

Another update will be provided within the next 1 hour.
Posted Jun 01, 2023 - 17:07 UTC
Investigating
We are currently investigating reports where videos in mobile devices are not rendering as expected, with and error message “The media could not be loaded, either because the server or network failed, or because the format is not supported.”

We will provide you with an update within the next 1 hour.
Posted Jun 01, 2023 - 16:32 UTC
This incident affected: Products (Mobile Experience).