EU Platform Service Disruption - Insights Reports Failing To Load Intermittently

Incident Report for Firstup

Resolved

Insights Reports have remained stable and fully available after the fix was released in the production environment.

This incident is now resolved. We will publish a Root Cause Analysis here once a full incident postmortem has been completed.
Posted Sep 09, 2026 - 21:10 UTC

Monitoring

We have fixed the underlying issue with loading Insights Reports and completed a data backfill task to restore any data that may have been missed in the reports.

We will be placing the affected components under monitoring for now.
Posted Sep 09, 2026 - 16:00 UTC

Identified

We have identified a potential root cause for this issue and are working towards mitigation.

Another update will be provided within the next 1 hour.
Posted Sep 09, 2026 - 15:00 UTC

Investigating

We are currently investigating reports where Insights Reports are intermittently failing to load for EU customers only.

We will provide an update within 1 hour.
Posted Sep 09, 2026 - 14:06 UTC
This incident affected: Products (Insights).