Some images requiring 3rd party transformation, not rendering as expected on Studio and Web Experience

Incident Report for Firstup

Postmortem

Summary:
On November 25th, customers experienced issues where images that required transformation (i.e., images with rounded corners, video preview images, inline images in rich text format) stopped displaying across various parts of the platform. It became evident that the failure was related to a third-party image processing partner inadvertently disabling a critical feature used by Firstup during an automated service renewal process.

All affected images began displaying normally once the configuration was fixed by the third-party provider.

Impact: 

  • Transformed images failed to display for customers.
  • No images were lost or corrupted; the issue solely affected their ability to be displayed.
  • Service returned to normal after the third-party provider corrected the configuration and cleared relevant caches.

Root Cause:
An incorrect change in service entitlements was made during the account renewal process with the provider. This misconfiguration impacted image delivery capabilities resulting in the “broken image” icon being displayed rather than the desired image.

Mitigation:
An incident was declared at 9:12 am PST. Upon clarifying the issue's scope and origin, engineers first validated that no recent Firstup code changes were responsible. Subsequent testing of image URLs and delivery paths led to the engagement of our third-party provider for deeper investigation. The provider confirmed the root cause was a misconfiguration in the account and their engineers applied a correction and cleared caches for the production environment, which subsequently restored image functionality.

Recurrence Prevention: The following has been identified as follow-up to commit to as a part of this process: 

  • Ensuring the necessary features are explicitly included in contract details during the contract negotiation process.
Posted Dec 04, 2025 - 00:06 UTC

Resolved

We've been able to confirm the issue is mitigated, and no further reports have been made. Marking this incident resolved.
Posted Nov 25, 2025 - 22:46 UTC

Monitoring

The issue affecting image transformations has been identified and mitigated, though there may be some residual effects related to caching. We're continuing to monitor the issue.
Posted Nov 25, 2025 - 18:28 UTC

Investigating

We are currently investigating an issue where some images requiring 3rd party transformation are not rendering as expected on Studio and Web Experience.
Posted Nov 25, 2025 - 17:49 UTC
This incident affected: Platforms (US Firstup Platform, EU Firstup Platform).