Platform Service Degradation - Comments Report Disabled

Incident Report for Firstup

Resolved

Our monitoring indicates that the Comments card in the Campaign Performance Report continues to function as expected. This incident is now resolved.
Posted May 07, 2026 - 19:13 UTC

Monitoring

The Comments card’s functionality has now been restored and is fully functional.
Posted May 07, 2026 - 17:04 UTC

Investigating

We identified an underlying issue where the Comments card in the Campaign Performance Report was not consistently displaying the correct data. As a precaution, this card was temporarily disabled while our Engineering team investigated and resolved the root cause.
 
This step was taken to ensure data accuracy and integrity.
Posted May 07, 2026 - 17:03 UTC
This incident affected: Products (Insights).