EU Communities - Email campaign sending delayed

Incident Report for Firstup

Resolved

No further indications of email deliverability issues have been observed or reported. This incident is resolved.
Posted Dec 19, 2025 - 22:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2025 - 16:15 UTC

Update

We are continuing to investigate this issue and are currently testing a potential solution.

Campaigns are sending; however, delivery delays are still occurring.
Posted Dec 19, 2025 - 15:37 UTC

Investigating

We are investigating a service disruption affecting email delivery on EU communities (US communities are not affected)

This may be causing delays in email delivery from campaigns.

Our next update will be in one hour.
Posted Dec 19, 2025 - 14:32 UTC
This incident affected: Products (Campaign Delivery).