Platform Service Degradation - Branding accent color shows as red

Incident Report for Firstup

Postmortem

Summary: On December 10, several customers observed that portions of their branded web experience appeared in red, instead of using the customer-selected accent color. An incident was declared after it was determined the issue affected multiple customers. 

The engineering team found that a prior internal update to a shared user-interface component had unintentionally removed color-related code that was still in use in production. When the web experience began using the updated version of this component after the December release cycle, this change caused the incorrect accent color to appear.

A hotfix was issued the same day to restore the correct behavior and normal functionality was fully recovered for all customers approximately one hour after the incident was declared.

Impact: 

  • Affected elements included:

    • Sign-in and notification buttons
    • Branded blocks
    • Content cards
    • "Like" indicators
    • The translate option
  • No functionality was hindered; the issue was visual only.

Root Cause: In early October, an update was made to an internal user-interface component. This update removed color-related code under the assumption that it was unused. However, parts of the web experience still depended on this code to correctly apply customer-selected accent colors.

When the December release updated the web experience to use the latest version of this component, the unintended removal of that code introduced a visual regression. As a result, certain UI elements defaulted to red instead of the correct customer-specific color.Mitigation: Once the incident was declared, engineers quickly identified the regression and traced it to the internal component update. A targeted hotfix was prepared and deployed to restore correct color functionality across all affected elements. The incident was fully resolved approximately one hour after formal declaration.

Recurrence Prevention: To minimize the likelihood of similar issues in the future, Firstup will take the following actions:

  • Strengthen regression testing when updating shared user-interface components, ensuring that changes are validated across all dependent surfaces.
Posted Dec 18, 2025 - 00:10 UTC

Resolved

All impacted services have remained stable and fully functional. This incident is now resolved. A Root Cause Assessment will be published here once a postmortem of the incident has been completed.
Posted Dec 12, 2025 - 18:47 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 10, 2025 - 19:17 UTC

Monitoring

The fix for this issue has now been released in the production environment. A browser refresh may be required to correct the impacted items.

This incident is now resolved, and the impacted services will be placed under monitoring for now.
Posted Dec 10, 2025 - 18:58 UTC

Update

The fix for this issue has been tested and is currently being deployed in the production environment.

We will provide you with another update once it has been released, or within 1 hour.
Posted Dec 10, 2025 - 18:52 UTC

Identified

We have identified a potential root cause for this issue and are currently testing a proposed fix.

Another update will be provided within 1 hour.
Posted Dec 10, 2025 - 17:53 UTC

Investigating

We are investigating reports where the selected branding color is showing up as red in the Employee Experience.

We will provide you with an update within 1 hour.
Posted Dec 10, 2025 - 17:49 UTC
This incident affected: Products (Web Experience).